<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="temp" content="for VaultPress">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.beachmetro.com/xmlrpc.php">

<title>The sky&#039;s the limit for happy-go-lucky OB - Beach Metro Community News</title>

<!-- This site is optimized with the Yoast SEO plugin v3.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.beachmetro.com/2017/03/10/skys-limit-happy-go-lucky-ob/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The sky&#039;s the limit for happy-go-lucky OB - Beach Metro Community News" />
<meta property="og:description" content="In my 2016 pet recap earlier this year, I officially declared my commitment to a beagle-positive outlook for 2017. I also mentioned Archer, the bashful Italian Greyhound with Happy Tails Rescue. At the time, he was still looking for a home. Now, I’ve got some positive news! He’s been adopted and has a new pesky [...]" />
<meta property="og:url" content="http://www.beachmetro.com/2017/03/10/skys-limit-happy-go-lucky-ob/" />
<meta property="og:site_name" content="Beach Metro Community News" />
<meta property="article:tag" content="beagle" />
<meta property="article:tag" content="Big On Beagles" />
<meta property="article:tag" content="Happy Tails Rescue" />
<meta property="article:tag" content="rescue dog" />
<meta property="article:section" content="Pet of the Month" />
<meta property="article:published_time" content="2017-03-10T09:00:06-05:00" />
<meta property="article:modified_time" content="2017-03-06T15:28:08-05:00" />
<meta property="og:updated_time" content="2017-03-06T15:28:08-05:00" />
<meta property="og:image" content="http://www.beachmetro.com/wp-content/uploads/2017/03/OB-1.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="676" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="In my 2016 pet recap earlier this year, I officially declared my commitment to a beagle-positive outlook for 2017. I also mentioned Archer, the bashful Italian Greyhound with Happy Tails Rescue. At the time, he was still looking for a home. Now, I’ve got some positive news! He’s been adopted and has a new pesky [...]" />
<meta name="twitter:title" content="The sky&#039;s the limit for happy-go-lucky OB - Beach Metro Community News" />
<meta name="twitter:image" content="http://www.beachmetro.com/wp-content/uploads/2017/03/OB-1.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//www.beachmetro.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Beach Metro Community News &raquo; Feed" href="http://www.beachmetro.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Beach Metro Community News &raquo; Comments Feed" href="http://www.beachmetro.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Beach Metro Community News &raquo; The sky&#8217;s the limit for happy-go-lucky OB Comments Feed" href="http://www.beachmetro.com/2017/03/10/skys-limit-happy-go-lucky-ob/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.beachmetro.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.4"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='digg-digg-css'  href='http://www.beachmetro.com/wp-content/plugins/digg-digg/css/diggdigg-style.css?ver=5.3.6' type='text/css' media='screen' />
<link rel='stylesheet' id='dw-focus-main-css'  href='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/css/dw-focus.min.css?ver=1.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-style-css'  href='http://www.beachmetro.com/wp-content/themes/dw-focus/style.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-print-css'  href='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/css/print.css?ver=1.2.6' type='text/css' media='print' />
<link rel='stylesheet' id='options_typography_Roboto+Slab-css'  href='http://fonts.googleapis.com/css?family=Roboto+Slab' type='text/css' media='all' />
<link rel='stylesheet' id='options_typography_Oswald-css'  href='http://fonts.googleapis.com/css?family=Oswald' type='text/css' media='all' />
<link rel='stylesheet' id='options_typography_PT+Sans-css'  href='http://fonts.googleapis.com/css?family=PT+Sans' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://www.beachmetro.com/wp-content/tablepress-combined.min.css?ver=5' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.2 - Universal disabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-20693582-1']);
	_gaq.push(['_gat._forceSSL']);
	_gaq.push(['_trackPageview']);

	(function () {
		var ga = document.createElement('script');
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(ga, s);
	})();

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://www.beachmetro.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/js/modernizr.min.js?ver=1.2.6'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/js/jquery-mobile.min.js?ver=1.3.2'></script>
<link rel='https://api.w.org/' href='http://www.beachmetro.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.beachmetro.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.beachmetro.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.6.4" />
<link rel='shortlink' href='http://www.beachmetro.com/?p=23228' />
<link rel="alternate" type="application/json+oembed" href="http://www.beachmetro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.beachmetro.com%2F2017%2F03%2F10%2Fskys-limit-happy-go-lucky-ob%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.beachmetro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.beachmetro.com%2F2017%2F03%2F10%2Fskys-limit-happy-go-lucky-ob%2F&#038;format=xml" />
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<link rel="icon" href="http://www.beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" sizes="32x32" />
<link rel="icon" href="http://www.beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" />
<meta name="msapplication-TileImage" content="http://www.beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" />
<link rel="stylesheet" href="http://www.beachmetro.com/wp-content/plugins/oiopub-direct/images/style/output.css?260" type="text/css" />
</head>

<body class="single single-post postid-23228 single-format-standard layout-boxed sidebar-right">
<div id="page" class="hfeed site">
	<header class="site-header">
		<div class="container">
			<div class="row hidden-xs hidden-sm">
				<div class="col-md-4">
																<a href="http://www.beachmetro.com/" rel="home" class="site-logo"><img src="http://v3.beachmetro.com/wp-content/uploads/2015/10/Logo230x1802.png" title="Beach Metro Community News"></a>
									</div>
								<div id="header-widgets" class="col-md-8"><aside id="text-11" class="widget widget_text">			<div class="textwidget"><script type="text/javascript" src="http://www.beachmetro.com/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=1"></script>
</div>
		</aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><div align="center" style="font-style:italic;padding-top:35px;">A non-profit newspaper serving the Beach, Beach Hill, Birch Cliff, Cliffside,<br>Crescent Town, East Danforth, Gerrard India Bazaar, and Upper Beach since 1972.</div></div>
		</aside></div>
							</div>
						<div class="navigation-wrap under-navigation-activated">
								<nav id="masthead" class="navbar navbar-default site-navigation" role="banner">
					<div class="navbar-header">
												<button class="navbar-toggle" data-toggle="collapse" data-target=".main-navigation"><i class="fa fa-bars"></i></button>
												<a href="http://www.beachmetro.com/" rel="home" class="site-brand navbar-brand visible-xs visible-sm">
																						<img src="http://v3.beachmetro.com/wp-content/uploads/2015/10/Logo100x50.png" title="Beach Metro Community News">
													</a>
													<button class="search-toggle visible-xs visible-sm" data-toggle="collapse" data-target=".under-navigation"><i class="fa fa-search"></i></button>
											</div>

					<div id="site-navigation" class="collapse navbar-collapse main-navigation" role="navigation">
						<ul id="menu-top-menu" class="nav navbar-nav navbar-left"><li class="menu-news"><a href="http://www.beachmetro.com/category/news/">News</a></li>
<li class="menu-calendar"><a href="http://www.beachmetro.com/top-menu-items/community-calendar/">Calendar</a></li>
<li class="menu-arts-entertainment"><a href="http://www.beachmetro.com/category/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li class="menu-sports"><a href="http://www.beachmetro.com/category/sports/">Sports</a></li>
<li class="dropdown menu-features"><a class="dropdown-toggle disabled" data-toggle="dropdown" data-target="#" href="http://www.beachmetro.com/category/features/">Features <b class="caret"></b></a>
<ul class="dropdown-menu">
	<li class="menu-deja-views"><a href="http://www.beachmetro.com/category/features/deja-views/">Deja Views</a></li>
	<li class="menu-everyone-has-a-story-to-tell"><a href="http://www.beachmetro.com/category/features/ehst/">Everyone Has a Story to Tell</a></li>
	<li class="menu-eye-on-business"><a href="http://www.beachmetro.com/category/columns/eye-on-business/">Eye on Business</a></li>
</ul>
</li>
<li class="current-post-ancestor dropdown menu-columns"><a class="dropdown-toggle disabled" data-toggle="dropdown" data-target="#" href="http://www.beachmetro.com/category/columns/">Columns <b class="caret"></b></a>
<ul class="dropdown-menu">
	<li class="menu-in-my-opinion"><a href="http://www.beachmetro.com/category/columns/in-my-opinion/">In My Opinion</a></li>
	<li class="menu-beach-memories"><a href="http://www.beachmetro.com/category/columns/beach-memories/">Beach Memories</a></li>
	<li class="menu-the-main-menu"><a href="http://www.beachmetro.com/category/columns/the-main-menu/">The Main Menu</a></li>
	<li class="menu-bottoms-up"><a href="http://www.beachmetro.com/category/columns/bottoms-up/">Bottoms Up</a></li>
	<li class="menu-reel-beach"><a href="http://www.beachmetro.com/category/columns/reel-beach/">Reel Beach</a></li>
	<li class="menu-on-the-wild-side"><a href="http://www.beachmetro.com/category/columns/on-the-wild-side/">On The Wild Side</a></li>
	<li class="current-post-ancestor active current-post-parent menu-pet-of-the-month"><a href="http://www.beachmetro.com/category/columns/pet-of-the-month/">Pet of the Month</a></li>
	<li class="menu-garden-views"><a href="http://www.beachmetro.com/category/columns/garden-views/">Garden Views</a></li>
	<li class="menu-design-and-style-views"><a href="http://www.beachmetro.com/category/columns/design-and-style-views/">Design and Style Views</a></li>
	<li class="menu-environment-views"><a href="http://www.beachmetro.com/category/columns/environment-views/">Environment Views</a></li>
	<li class="menu-horticultural-matters"><a href="http://www.beachmetro.com/category/columns/horticultural-matters/">Horticultural Matters</a></li>
	<li class="menu-legal-matters"><a href="http://www.beachmetro.com/category/columns/legal-matters/">Legal Matters</a></li>
	<li class="menu-nutrition-matters"><a href="http://www.beachmetro.com/category/columns/nutrition-matters/">Nutrition Matters</a></li>
	<li class="menu-on-the-child-side"><a href="http://www.beachmetro.com/category/columns/on-the-child-side/">On The Child Side</a></li>
	<li class="menu-open-doors"><a href="http://www.beachmetro.com/category/columns/open-doors/">Open Doors</a></li>
	<li class="menu-real-estate-matters"><a href="http://www.beachmetro.com/category/columns/real-estate-matters/">Real Estate Matters</a></li>
	<li class="menu-veterinary-views"><a href="http://www.beachmetro.com/category/columns/veterinary-views/">Veterinary Views</a></li>
	<li class="dropdown menu-archived-columns"><a href="http://www.beachmetro.com/category/columns/archived-columns/">Archived columns</a>
<ul class="dropdown-menu">
		<li class="menu-a-childs-world"><a href="http://www.beachmetro.com/category/columns/archived-columns/a-childs-world/">A Child&#8217;s World</a></li>
		<li class="menu-glenn-cochranes-corner"><a href="http://www.beachmetro.com/category/columns/archived-columns/glenn-cochranes-corner/">Glenn Cochrane&#8217;s Corner</a></li>
		<li class="menu-money-life-and-law"><a href="http://www.beachmetro.com/category/columns/archived-columns/money-life-and-law/">Money, Life and Law</a></li>
		<li class="menu-school-views"><a href="http://www.beachmetro.com/category/columns/archived-columns/school-views/">School Views</a></li>
		<li class="menu-school-daze"><a href="http://www.beachmetro.com/category/columns/archived-columns/school-daze/">School Daze</a></li>
		<li class="menu-welcome-at-home"><a href="http://www.beachmetro.com/category/columns/archived-columns/welcome-at-home/">Welcome at Home</a></li>
		<li class="menu-where-are-they-now"><a href="http://www.beachmetro.com/category/columns/archived-columns/where-are-they-now/">Where Are They Now?</a></li>
		<li class="menu-write-on-health"><a href="http://www.beachmetro.com/category/columns/archived-columns/write-on-health/">Write on Health</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-letters"><a href="http://www.beachmetro.com/category/letters/">Letters</a></li>
<li class="menu-directory"><a href="http://www.beachmetro.com/top-menu-items/business-directory/">Directory</a></li>
<li class="menu-classifieds"><a href="http://www.beachmetro.com/top-menu-items/classifieds/">Classifieds</a></li>
</ul>						<div class="hidden-xs hidden-sm">		<ul class="nav navbar-nav navbar-right">
			<li class="facebook"><a href="http://www.facebook.com/BeachMetroNews" class="external" rel="nofollow" target="_blank"><i class="fa fa-facebook"></i></a></li><li class="twitter"><a href="http://twitter.com/beachmetronews" class="external" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i></a></li>			<li class="rss"><a href="http://www.beachmetro.com/feed/"><i class="fa fa-rss"></i></a></li>
		</ul>
	</div>
					</div>
				</nav>

								<div class="under-navigation hidden-xs hidden-sm">
					<div class="row">
						<div class="col-md-9 hidden-xs hidden-sm">		<aside id="news-ticker-3" class="widget dw_focus_widget_news_ticker">		<h2 class="widget-title">Trending Now</h2>		<div class="news-ticker-wrap headlines" data-interval="4000">
			<ul>
							<li>
					<a href="http://www.beachmetro.com/2017/03/10/skys-limit-happy-go-lucky-ob/">The sky&#8217;s the limit for happy-go-lucky OB</a>
									<span class="post-date">March 10, 2017</span>
								</li>
							<li>
					<a href="http://www.beachmetro.com/2017/03/09/winter-station-midwinter-fire-removed-early-due-vandalism/">Winter Station &#8220;Midwinter Fire&#8221; to be removed early due to vandalism</a>
									<span class="post-date">March 9, 2017</span>
								</li>
							<li>
					<a href="http://www.beachmetro.com/2017/03/09/public-art-proposals-displayed-beaches-library/">Public art proposals displayed at Beaches Library</a>
									<span class="post-date">March 9, 2017</span>
								</li>
							<li>
					<a href="http://www.beachmetro.com/2017/03/09/bowmore-students-hit-big-screen/">Bowmore students hit the big screen</a>
									<span class="post-date">March 9, 2017</span>
								</li>
							<li>
					<a href="http://www.beachmetro.com/2017/03/09/grows-yellow-house-gallery/">All That Grows at the Yellow House Gallery</a>
									<span class="post-date">March 9, 2017</span>
								</li>
						</ul>
		</div>
		</aside>		</div>
						<div class="col-md-3"><form method="get" id="searchform" action="http://www.beachmetro.com/">
	<input type="text" name="s" id="s" class="form-control" value="" placeholder="Search">
	<input type="submit" class="search-submit">
</form>
</div>
					</div>
				</div>
							</div>
		</div>
	</header>

	<div id="content" class="site-content">
<div class="container">
	<div class="content-inner">
		<div class="row">
			<div class="col-lg-9">
				<div id="primary" class="content-area">
					<main id="main" class="site-main" role="main">
											
												
	<article id="post-23228" class="post-23228 post type-post status-publish format-standard has-post-thumbnail hentry category-pet-of-the-month tag-beagle tag-big-on-beagles tag-happy-tails-rescue tag-rescue-dog">
		<header class="entry-header">
			<h1 class="entry-title">The sky&#8217;s the limit for happy-go-lucky OB</h1>
			<div class="entry-meta">
				<span class="posted-on"><i class="fa fa-clock-o"></i> <a href="http://www.beachmetro.com/2017/03/10/skys-limit-happy-go-lucky-ob/" rel="bookmark"><span class="entry-date published">March 10, 2017</span><span class="updated sr-only">March 6, 2017</span></a></span><span class="byline"> <i class="fa fa-user"></i> <span class="author vcard">Marna Gale</span></span></span>
			</div>
		</header>

		

	<div class="row">
		<div class="entry-content col-md-9 col-md-push-3">
							<div class="entry-thumbnail"><img width="900" height="676" src="http://www.beachmetro.com/wp-content/uploads/2017/03/OB-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="OB" srcset="http://www.beachmetro.com/wp-content/uploads/2017/03/OB-1.jpg 900w, http://www.beachmetro.com/wp-content/uploads/2017/03/OB-1-300x225.jpg 300w, http://www.beachmetro.com/wp-content/uploads/2017/03/OB-1-768x577.jpg 768w, http://www.beachmetro.com/wp-content/uploads/2017/03/OB-1-230x173.jpg 230w" sizes="(max-width: 900px) 100vw, 900px" /><div class="ccfic"><span class="ccfic-text">Happy OB waits patiently to go for his walk.</span> <span class="ccfic-source">PHOTO: Marna Gale</span></div></div>
						<a id="dd_start"></a><p>In my 2016 pet recap earlier this year, I officially declared my commitment to a beagle-positive outlook for 2017. I also mentioned Archer, the bashful Italian Greyhound with Happy Tails Rescue. At the time, he was still looking for a home. Now, I’ve got some positive news! He’s been adopted and has a new pesky little Italian Greyhound brother named Enzo who has made it his mission to release Archer’s inner bad boy for a lifetime of brotherly mischief! Watch for the canine version of “The Italian Job” coming soon to a theatre near you.</p>
<p>Getting back to my resolution of positivity, I’m delighted to report things are going well. I’ve even got a tour guide to keep me on that perky path to happy town. His name is OB and he’s our first rescued beagle of the year.</p>
<p>OB is the happiest of happy-go-lucky beagles – this despite the fact that if it weren’t for bad luck he’d have no luck at all. Weighing in at a knee-buckling 70lbs, he is the most obese beagle we’ve rescued to date. And that’s just one example of his woes.</p>
<p>He’s got a grocery list of medical conditions left untreated by his previous owner, starting with a full-blown bout of cherry eye in both eyes. A painful case of cauliflower ear has impacted both ears, more likely due to severe infection than consequences from a wrestling career. We’ve yet to conclude whether OB will require ear surgery. In the meantime, we’re trying a topical treatment like the one we are using for a possible allergy-related inflammation of all four paws and one otherwise gleeful tail.</p>
<p>There were easier fixes than the ones above, but that’s not to say they weren’t uncomfortable for poor OB.</p>
<p>His nails were so overgrown they had curled under with some actually embedded in the pads of his feet. He was also sporting a skin tag that had grown so long he was tripping over it, but that was easily removed under local anesthetic.</p>
<p>He may have good reason to feel gloom, despair and agony, but nine-year-old OB refuses to let any of it weigh him down – he is gravity-defying and in far more ways than one. The first indication of his incredible lightness of being was entirely literal when he effortlessly hopped up on the best, most cushiony chair in the house the night before heading to his foster home. I suppose “people furniture” is much more appealing than a lowly dog bed on the floor, especially after a long and torturous week at the vets. Although, true to character, OB didn’t seem to mind his hospital stay. The girls at the front desk served as a pleasant distraction from all the medical procedures. By the time he was ready to leave, our little ladies man had his own personal entourage.</p>
<p>Perhaps his unabashed love for comfy furniture and doting humans, including ones armed with stethoscopes, are proof that OB was at least the recipient of past affections. Better than nothing, if we’re going to think like a beagle. Mind you, a beagle would have you think there’s nothing wrong with eating junk food until you burst like the greedy kid touring the Willy Wonka factory. But over indulgence can turn you into something much worse than a giant blueberry.</p>
<p>He may not have burst, but OB’s weight has put him at high risk of health complications. The extra pressure on his joints can lead to arthritis which can lead to torn ligaments of the knee which can lead to costly surgery. In fact, Algernon, my Mr. November, is undergoing that procedure this month.</p>
<p>Obesity can also contribute to high blood pressure and heart disease which results in greater risk under anesthetic. This is why corrective surgery for OB’s cherry eye must wait until he’s significantly lighter. There are other concerns, but above all, there is quite simply the concern for quality of life. Happy, healthy dogs have an enviable way of living life to the fullest in every moment even if that means sniffing the same blade of grass for what seems an eternity to the person at the other end of the leash.</p>
<p>It will take at least three months to lighten OB’s load. Having ruled out a thyroid issue, we can safely assume the weight is entirely due to overfeeding and that he was fed low-quality food (although I’m sure he’d disagree with us). Judging from his disdain for every canine diet offered him, OB’s brand of choice until now must have been “people food”. Hard-wired for hot dogs, the transition won’t be easy but it’s not impossible. Remember, OB is a positive guy. We just need to re-direct that positivity towards a wholesome prescription kibble! OK, maybe I’m more positive than he is in this category.</p>
<p>It’s been about a month now and we’re seeing progress. He’s gone from a Size 8 harness to the loosest notch on a standard beagle Size 7! He’s also gradually matching that peppy personality to his step and the great outdoors is coaxing him to finally venture beyond his initially brief duck waddles to the back deck and embrace the glorious expanse of yard below. This has led him to the unexpected but magnificent discovery of mud! He’s taken to tossing toys up in the air too, but only when mud is not available.</p>
<p>After a day of mud-slinging, mandatory paw cleaning, indoor toy tossing and grimacing through another blah dinner meant for dogs only, he’s one pooped pooch. That’s when he’s ready for his last activity of the day – sawing logs smack dab in front of the TV. It’s especially endearing when his foster mommy is straining her ears to enjoy that movie she’s been looking forward to all week. I can sympathize as I’ve got my share of high volume snorers but the truth is we both know the sound is music to our ears.</p>
<p>They say bumblebees shouldn’t be able to fly and yet, somehow, they can. Just as it is for gravity-defying beagles like OB for whom the sky above isn’t even the limit. For OB, the possibilities are endless!</p>
<p>OB is a nine-year-old beagle bursting with optimism at Big On Beagles Rescue, <a href="http://www.bigonbeagles.ca" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'http://www.bigonbeagles.ca', 'www.bigonbeagles.ca']);"  class="external" rel="nofollow" target="_blank">www.bigonbeagles.ca</a>. Follow his journey to good health and just maybe, his ultimate destination will be YOUR best seat in the house. In the meantime, our sincere thanks to Catherine &amp; Bill of Sheba’s Haven Rescue for their role as foster parents to our OB.</p>
<a id="dd_end"></a><div class='dd_outer'><div class='dd_inner'><div id='dd_ajax_float'><div class='dd_button_v'><a href="http://twitter.com/share" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'http://twitter.com/share', '']);" class="twitter-share-button external" data-url="http://www.beachmetro.com/2017/03/10/skys-limit-happy-go-lucky-ob/" data-count="vertical" data-text="The sky's the limit for happy-go-lucky OB" data-via="" rel="nofollow" target="_blank"></a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></div><div style='clear:left'></div><div class='dd_button_v'><a href="http://www.facebook.com/sharer.php" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'http://www.facebook.com/sharer.php', '']);" name='fb_share' type='box_count' share_url='http://www.beachmetro.com/2017/03/10/skys-limit-happy-go-lucky-ob/' class="external" rel="nofollow" target="_blank"></a><script src='http://static.ak.fbcdn.net/connect.php/js/FB.Share' type='text/javascript'></script></div><div style='clear:left'></div><div class='dd_button_v'><script type='text/javascript' src='https://apis.google.com/js/plusone.js'></script><g:plusone size='tall' href='http://www.beachmetro.com/2017/03/10/skys-limit-happy-go-lucky-ob/'></g:plusone></div><div style='clear:left'></div><div class='dd_button_extra_v'><script type="text/javascript">jQuery(document).load(function(){ stLight.options({publisher:''}); });</script><div class="st_email_custom"><span id='dd_email_text'>email</span></div></div><div style='clear:left'></div><div class='dd_button_extra_v'><div id='dd_print_button'><span id='dd_print_text'><a href='javascript:window:print()'>print</a></span></div></div><div style='clear:left'></div></div></div></div><script type="text/javascript">var dd_offset_from_content = 40;var dd_top_offset_from_content = 0;var dd_override_start_anchor_id = "";var dd_override_top_offset = "";</script><script type="text/javascript" src="http://www.beachmetro.com/wp-content/plugins/digg-digg//js/diggdigg-floating-bar.js?ver=5.3.6"></script>						</div>
			<div class="entry-sidebar col-md-3 col-md-pull-9">
								
			</div>
		</div>


	</article>
												
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://www.beachmetro.com/2017/03/09/winter-station-midwinter-fire-removed-early-due-vandalism/" rel="prev">Winter Station &#8220;Midwinter Fire&#8221; to be removed early due to vandalism</a></div></div>
	</nav>						
<section id="comments" class="comments">
	
	<a href="beach-metro-news-commenting-guidelines-policy" target="_new">Click here</a> for our commenting guidelines.
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/03/10/skys-limit-happy-go-lucky-ob/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.beachmetro.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<p class="comment-form"><label for="comment">Comment</label><textarea id="comment" name="comment" class="form-control" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" class="form-control" aria-required=true /></p>
<p class="comment-form-email"><label for="email">Email</label> <span class="required">*</span><input id="email" name="email" type="text" value="" class="form-control" aria-required=true /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-default" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='23228' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="60e2250fba" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="51"/></p>				</form>
					</div><!-- #respond -->
		</section>										</main>
				</div>
			</div>
			<div class="col-lg-3">
				
<div id="secondary" class="widget-area" role="complementary">
	<aside id="recent-comments-5" class="widget widget_recent_comments"><h2 class="widget-title">WHAT PEOPLE ARE SAYING</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">AngieA</span> on <a href="http://www.beachmetro.com/2017/03/08/former-leuty-lifeguard-wants-hear/#comment-452196">Former Leuty lifeguard wants to hear from you</a></li><li class="recentcomments"><span class="comment-author-link">Michael Provost</span> on <a href="http://www.beachmetro.com/2017/03/09/winter-station-midwinter-fire-removed-early-due-vandalism/#comment-452195">Winter Station &#8220;Midwinter Fire&#8221; to be removed early due to vandalism</a></li><li class="recentcomments"><span class="comment-author-link">Paul Starling</span> on <a href="http://www.beachmetro.com/2017/03/07/close-50-years-beloved-beach-doctor-retires/#comment-452184">After close to 50 years, beloved Beach doctor retires</a></li><li class="recentcomments"><span class="comment-author-link">Ira Black</span> on <a href="http://www.beachmetro.com/2017/03/09/winter-station-midwinter-fire-removed-early-due-vandalism/#comment-452183">Winter Station &#8220;Midwinter Fire&#8221; to be removed early due to vandalism</a></li><li class="recentcomments"><span class="comment-author-link">Klaus Held</span> on <a href="http://www.beachmetro.com/2017/03/07/close-50-years-beloved-beach-doctor-retires/#comment-452180">After close to 50 years, beloved Beach doctor retires</a></li></ul></aside><aside id="text-13" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive 1 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3515823420161132"
     data-ad-slot="4234949459"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside></div>
			</div>
		</div>
	</div>
</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="container">
			<div class="footer-navigation"></div>
<div id="footer-widgets" class="widget-area" role="complementary">
	<div class="row">
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-7" class="widget widget_nav_menu"><ul id="menu-bottom-left" class="menu"><li class="menu-become-a-volunteer"><a href="http://www.beachmetro.com/bottom-left-items/become-a-volunteer/">Become a Volunteer</a></li>
<li class="menu-frequently-asked-questions"><a href="http://www.beachmetro.com/bottom-left-items/faq/">Frequently Asked Questions</a></li>
<li class="menu-contact-us"><a href="http://www.beachmetro.com/bottom-left-items/contact-us/">Contact Us</a></li>
<li class="menu-about-us"><a href="http://www.beachmetro.com/bottom-left-items/about-us/">About Us</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-8" class="widget widget_nav_menu"><ul id="menu-bottom-middle" class="menu"><li class="menu-distribution-map"><a href="http://www.beachmetro.com/bottom-middle-items/distribution-map/">Distribution Map</a></li>
<li class="menu-2017-publication-schedule"><a href="http://www.beachmetro.com/bottom-middle-items/publication-schedule/">2017 Publication Schedule</a></li>
<li class="menu-advertising-rates"><a href="http://www.beachmetro.com/bottom-middle-items/advertising-rates/">Advertising Rates</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-9" class="widget widget_nav_menu"><ul id="menu-bottom-right" class="menu"><li class="menu-careers"><a href="http://www.beachmetro.com/careers/">Careers</a></li>
<li class="menu-suddicks-take"><a href="http://www.beachmetro.com/category/suddicks-take/">Suddick&#8217;s Take</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-md-4 col-lg-offset-0 col-md-offset-2 col-sm-5 col-sm-offset-1"></div>
	</div>
</div>
			<div class="row">
				<div class="site-info col-md-6">
					Copyright &copy; 2017 by <br><a href="http://www.beachmetro.com" rel="designer">Beach Metro Community News</a>.					<br>
				</div>

			</div>
		</div>
	</footer>
</div>

<!-- Start Of Script Generated By Greg's Comment Length Limiter Plugin 1.6.5 -->
<script type="text/javascript">
<!--
function gcllCounter(textarea) {
if (textarea.value.length > 1500)
textarea.value = textarea.value.substring(0, 1500);
else
document.getElementById('commentlen').value = 1500 - textarea.value.length;
}
//-->
</script>
<!-- End of Script Generated By Greg's Comment Length Limiter Plugin 1.6.5 --><style type="text/css">a { color: #487db6}
a:hover, a:active { color: #ba534a}
body { background: url() #474747 repeat top center scroll}
.site-header { background: url()  repeat top center scroll}
.site-footer { color: #555555}
.site-footer a { color: #777777}
.site-footer a:hover, .site-footer a:active { color: #ffffff}
.site-footer #footer-widgets .widget-title { color: #ffffff}
.site-footer .footer-navigation, #footer-widgets { border-color: #a8a8a8}
#footer-widgets .widget_nav_menu:after { background-color: #a8a8a8}
 .site-footer { background: url() #01202b repeat top center scroll}
body { color:#333333; font-family:Roboto Slab, serif; font-size:14px; }
h1 { color:#333333; font-family:Oswald, sans-serif; font-size:36px; }
h2 { color:#333333; font-family:Oswald, sans-serif; font-size:30px; }
h3 { color:#333333; font-family:Oswald, sans-serif; font-size:30px; }
h4 { color:#333333; font-family:Oswald, sans-serif; font-size:18px; }
h5 { color:#333333; font-family:Oswald, sans-serif; font-size:14px; }
h6 { color:#333333; font-family:PT Sans, sans-serif; font-size:12px; }
</style><script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='http://w.sharethis.com/button/buttons.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-includes/js/comment-reply.min.js?ver=4.6.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"http:\/\/www.beachmetro.com\/wp-admin\/admin-ajax.php"};
var sharrre = {"sharrre_url":"http:\/\/www.beachmetro.com\/wp-content\/themes\/dw-focus\/inc\/sharrre.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/js/dw-focus.min.js?ver=1.2.6'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-includes/js/wp-embed.min.js?ver=4.6.4'></script>

</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

 Served from: beachmetro.com @ 2017-03-10 09:58:48 by W3 Total Cache -->