<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="temp" content="for VaultPress">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.beachmetro.com/xmlrpc.php">

<title>Sweet citrus and decadent chocolate are sure to delight the senses - Beach Metro Community News</title>

<!-- This site is optimized with the Yoast SEO plugin v3.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.beachmetro.com/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Sweet citrus and decadent chocolate are sure to delight the senses - Beach Metro Community News" />
<meta property="og:description" content="There’s no getting away from it – sweets are my downfall! But not just any sweet thing. Keep your nondescript candy, ice-cream and sugary fluffy desserts to yourself. But, a sensational sweet &#8212; that’s another matter. I like my sweets rich, bursting with intense flavour, preferably lemon, and if it should be chocolate – it [...]" />
<meta property="og:url" content="http://www.beachmetro.com/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/" />
<meta property="og:site_name" content="Beach Metro Community News" />
<meta property="article:tag" content="baked goods" />
<meta property="article:tag" content="baking" />
<meta property="article:tag" content="hazelnut mocha torte" />
<meta property="article:tag" content="lemon loaf" />
<meta property="article:section" content="The Main Menu" />
<meta property="article:published_time" content="2017-04-24T09:37:00-04:00" />
<meta property="article:modified_time" content="2017-04-18T13:38:12-04:00" />
<meta property="og:updated_time" content="2017-04-18T13:38:12-04:00" />
<meta property="og:image" content="http://www.beachmetro.com/wp-content/uploads/2017/04/Lemons_5836497465.jpg" />
<meta property="og:image:width" content="3364" />
<meta property="og:image:height" content="2242" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="There’s no getting away from it – sweets are my downfall! But not just any sweet thing. Keep your nondescript candy, ice-cream and sugary fluffy desserts to yourself. But, a sensational sweet &#8212; that’s another matter. I like my sweets rich, bursting with intense flavour, preferably lemon, and if it should be chocolate – it [...]" />
<meta name="twitter:title" content="Sweet citrus and decadent chocolate are sure to delight the senses - Beach Metro Community News" />
<meta name="twitter:image" content="http://www.beachmetro.com/wp-content/uploads/2017/04/Lemons_5836497465.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//www.beachmetro.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Beach Metro Community News &raquo; Feed" href="http://www.beachmetro.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Beach Metro Community News &raquo; Comments Feed" href="http://www.beachmetro.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Beach Metro Community News &raquo; Sweet citrus and decadent chocolate are sure to delight the senses Comments Feed" href="http://www.beachmetro.com/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.beachmetro.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='digg-digg-css'  href='http://www.beachmetro.com/wp-content/plugins/digg-digg/css/diggdigg-style.css?ver=5.3.6' type='text/css' media='screen' />
<link rel='stylesheet' id='magnific-css'  href='http://www.beachmetro.com/wp-content/plugins/ignitiondeck/lib/magnific/magnific.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='idf-css'  href='http://www.beachmetro.com/wp-content/plugins/ignitiondeck/css/idf.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ignitiondeck-base-css'  href='http://www.beachmetro.com/wp-content/plugins/ignitiondeck-crowdfunding/ignitiondeck-base.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ignitiondeck-style-css'  href='http://www.beachmetro.com/wp-content/plugins/ignitiondeck-crowdfunding/skins/ignitiondeck-style.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='idcommerce-css'  href='http://www.beachmetro.com/wp-content/plugins/idcommerce/css/style.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-main-css'  href='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/css/dw-focus.min.css?ver=1.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-style-css'  href='http://www.beachmetro.com/wp-content/themes/dw-focus/style.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-print-css'  href='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/css/print.css?ver=1.2.6' type='text/css' media='print' />
<link rel='stylesheet' id='options_typography_Roboto+Slab-css'  href='http://fonts.googleapis.com/css?family=Roboto+Slab' type='text/css' media='all' />
<link rel='stylesheet' id='options_typography_Oswald-css'  href='http://fonts.googleapis.com/css?family=Oswald' type='text/css' media='all' />
<link rel='stylesheet' id='options_typography_PT+Sans-css'  href='http://fonts.googleapis.com/css?family=PT+Sans' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://www.beachmetro.com/wp-content/tablepress-combined.min.css?ver=5' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.2 - Universal disabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-20693582-1']);
	_gaq.push(['_gat._forceSSL']);
	_gaq.push(['_trackPageview']);

	(function () {
		var ga = document.createElement('script');
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(ga, s);
	})();

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://www.beachmetro.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var idf_platform = "idc";
var idf_siteurl = "http:\/\/www.beachmetro.com";
var idf_ajaxurl = "http:\/\/www.beachmetro.com\/wp-admin\/admin-ajax.php";
var idf_logged_in = "0";
var idf_checkout_url = [""];
/* ]]> */
</script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/ignitiondeck/js/idf.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/ignitiondeck/lib/magnific/magnific.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/ignitiondeck/js/idf-stock-browser.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/ignitiondeck-crowdfunding/js/jquery.ddslick.min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var id_ajaxurl = "\/wp-admin\/admin-ajax.php";
var id_siteurl = "http:\/\/www.beachmetro.com\/";
/* ]]> */
</script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/ignitiondeck-crowdfunding/js/ignitiondeck.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var memberdeck_epp = "0";
var memberdeck_es = "0";
var memberdeck_mc = "0";
var memberdeck_ecb = "0";
var memberdeck_eauthnet = "0";
var memberdeck_eppadap = "0";
var memberdeck_ajaxurl = "http:\/\/www.beachmetro.com\/wp-admin\/admin-ajax.php";
var memberdeck_siteurl = "http:\/\/www.beachmetro.com\/";
var memberdeck_pluginsurl = "http:\/\/www.beachmetro.com\/wp-content\/plugins\/idcommerce";
var memberdeck_durl = "http:\/\/www.beachmetro.com\/dashboard\/";
var idc_localization_strings = {"virtual_currency":"Virtual Currency","purchase_form_shortcode":"Purchase form shortcode","continue":"Continue","complete_checkout":"Complete Checkout","use_idcf_settings":"Use IDCF Setting","continue_checkout":"Continue Checkout","choose_product":"Choose Product","choose_download":"Choose Download","choose_credit":"Choose Credit","no_payment_options":"No Payment Options","select_payment_option":"Select Payment Option","pay_with_credits":"Pay with Credits","processing":"Processing","choose_payment_method":"Choose Payment Method","pay_with_cc":"Pay with Credit Card","pay_with_paypal":"Pay with Paypal","pay_with_coinbase":"Pay with Coinbase","no_payments_available":"No Payment Options Available","pass_dont_match":"Passwords do not match","strip_credentials_problem_text":"There is a problem with your Stripe credentials","passwords_mismatch_text":"Passwords do not match","accept_terms":"Please accept our","error_in_processing_registration_text":"There was an error processing your registration. Please contact site administrator for assistance","complete_all_fields":"Please complete all fields.","registeration_fields_error_text":"Please complete all fields and ensure password 5+ characters.","email_already_exists":"Email already exists","please":"Please","login":"Login","update":"Update"};
var permalink_prefix = "?";
var is_idc_free = "1";
/* ]]> */
</script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/idcommerce/js/idcommerce.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/idcommerce/js/lightbox.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/js/modernizr.min.js?ver=1.2.6'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/js/jquery-mobile.min.js?ver=1.3.2'></script>
<link rel='https://api.w.org/' href='http://www.beachmetro.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.beachmetro.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.beachmetro.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='http://www.beachmetro.com/?p=23998' />
<link rel="alternate" type="application/json+oembed" href="http://www.beachmetro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.beachmetro.com%2F2017%2F04%2F24%2Fsweet-citrus-decadent-chocolate-sure-delight-senses%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.beachmetro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.beachmetro.com%2F2017%2F04%2F24%2Fsweet-citrus-decadent-chocolate-sure-delight-senses%2F&#038;format=xml" />
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<link rel="icon" href="http://www.beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" sizes="32x32" />
<link rel="icon" href="http://www.beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" />
<meta name="msapplication-TileImage" content="http://www.beachmetro.com/wp-content/uploads/2015/11/BMN-LOGO2015-lorezFAVICON.jpg" />
<link rel="stylesheet" href="http://www.beachmetro.com/wp-content/plugins/oiopub-direct/images/style/output.css?260" type="text/css" />
</head>

<body class="post-template-default single single-post postid-23998 single-format-standard layout-boxed sidebar-right">
<div id="page" class="hfeed site">
	<header class="site-header">
		<div class="container">
			<div class="row hidden-xs hidden-sm">
				<div class="col-md-4">
																<a href="http://www.beachmetro.com/" rel="home" class="site-logo"><img src="http://v3.beachmetro.com/wp-content/uploads/2015/10/Logo230x1802.png" title="Beach Metro Community News"></a>
									</div>
								<div id="header-widgets" class="col-md-8"><aside id="text-11" class="widget widget_text">			<div class="textwidget"><script type="text/javascript" src="http://www.beachmetro.com/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=1"></script>
</div>
		</aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><div align="center" style="font-style:italic;padding-top:35px;">A non-profit newspaper serving the Beach, Beach Hill, Birch Cliff, Cliffside,<br>Crescent Town, East Danforth, Gerrard India Bazaar, and Upper Beach since 1972.</div></div>
		</aside></div>
							</div>
						<div class="navigation-wrap under-navigation-activated">
								<nav id="masthead" class="navbar navbar-default site-navigation" role="banner">
					<div class="navbar-header">
												<button class="navbar-toggle" data-toggle="collapse" data-target=".main-navigation"><i class="fa fa-bars"></i></button>
												<a href="http://www.beachmetro.com/" rel="home" class="site-brand navbar-brand visible-xs visible-sm">
																						<img src="http://v3.beachmetro.com/wp-content/uploads/2015/10/Logo100x50.png" title="Beach Metro Community News">
													</a>
													<button class="search-toggle visible-xs visible-sm" data-toggle="collapse" data-target=".under-navigation"><i class="fa fa-search"></i></button>
											</div>

					<div id="site-navigation" class="collapse navbar-collapse main-navigation" role="navigation">
						<ul id="menu-top-menu" class="nav navbar-nav navbar-left"><li class="menu-news"><a href="http://www.beachmetro.com/category/news/">News</a></li>
<li class="menu-calendar"><a href="http://www.beachmetro.com/top-menu-items/community-calendar/">Calendar</a></li>
<li class="menu-arts-entertainment"><a href="http://www.beachmetro.com/category/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li class="menu-sports"><a href="http://www.beachmetro.com/category/sports/">Sports</a></li>
<li class="dropdown menu-features"><a class="dropdown-toggle disabled" data-toggle="dropdown" data-target="#" href="http://www.beachmetro.com/category/features/">Features <b class="caret"></b></a>
<ul class="dropdown-menu">
	<li class="menu-deja-views"><a href="http://www.beachmetro.com/category/features/deja-views/">Deja Views</a></li>
	<li class="menu-everyone-has-a-story-to-tell"><a href="http://www.beachmetro.com/category/features/ehst/">Everyone Has a Story to Tell</a></li>
	<li class="menu-eye-on-business"><a href="http://www.beachmetro.com/category/columns/eye-on-business/">Eye on Business</a></li>
</ul>
</li>
<li class="current-post-ancestor dropdown menu-columns"><a class="dropdown-toggle disabled" data-toggle="dropdown" data-target="#" href="http://www.beachmetro.com/category/columns/">Columns <b class="caret"></b></a>
<ul class="dropdown-menu">
	<li class="menu-in-my-opinion"><a href="http://www.beachmetro.com/category/columns/in-my-opinion/">In My Opinion</a></li>
	<li class="menu-beach-memories"><a href="http://www.beachmetro.com/category/columns/beach-memories/">Beach Memories</a></li>
	<li class="current-post-ancestor active current-post-parent menu-the-main-menu"><a href="http://www.beachmetro.com/category/columns/the-main-menu/">The Main Menu</a></li>
	<li class="menu-bottoms-up"><a href="http://www.beachmetro.com/category/columns/bottoms-up/">Bottoms Up</a></li>
	<li class="menu-reel-beach"><a href="http://www.beachmetro.com/category/columns/reel-beach/">Reel Beach</a></li>
	<li class="menu-on-the-wild-side"><a href="http://www.beachmetro.com/category/columns/on-the-wild-side/">On The Wild Side</a></li>
	<li class="menu-pet-of-the-month"><a href="http://www.beachmetro.com/category/columns/pet-of-the-month/">Pet of the Month</a></li>
	<li class="menu-garden-views"><a href="http://www.beachmetro.com/category/columns/garden-views/">Garden Views</a></li>
	<li class="menu-design-and-style-views"><a href="http://www.beachmetro.com/category/columns/design-and-style-views/">Design and Style Views</a></li>
	<li class="menu-east-ender"><a href="http://www.beachmetro.com/category/columns/east-ender/">East Ender</a></li>
	<li class="menu-environment-views"><a href="http://www.beachmetro.com/category/columns/environment-views/">Environment Views</a></li>
	<li class="menu-horticultural-matters"><a href="http://www.beachmetro.com/category/columns/horticultural-matters/">Horticultural Matters</a></li>
	<li class="menu-legal-matters"><a href="http://www.beachmetro.com/category/columns/legal-matters/">Legal Matters</a></li>
	<li class="menu-nutrition-matters"><a href="http://www.beachmetro.com/category/columns/nutrition-matters/">Nutrition Matters</a></li>
	<li class="menu-on-the-child-side"><a href="http://www.beachmetro.com/category/columns/on-the-child-side/">On The Child Side</a></li>
	<li class="menu-open-doors"><a href="http://www.beachmetro.com/category/columns/open-doors/">Open Doors</a></li>
	<li class="menu-real-estate-matters"><a href="http://www.beachmetro.com/category/columns/real-estate-matters/">Real Estate Matters</a></li>
	<li class="menu-veterinary-views"><a href="http://www.beachmetro.com/category/columns/veterinary-views/">Veterinary Views</a></li>
	<li class="dropdown menu-archived-columns"><a href="http://www.beachmetro.com/category/columns/archived-columns/">Archived columns</a>
<ul class="dropdown-menu">
		<li class="menu-a-childs-world"><a href="http://www.beachmetro.com/category/columns/archived-columns/a-childs-world/">A Child&#8217;s World</a></li>
		<li class="menu-glenn-cochranes-corner"><a href="http://www.beachmetro.com/category/columns/archived-columns/glenn-cochranes-corner/">Glenn Cochrane&#8217;s Corner</a></li>
		<li class="menu-money-life-and-law"><a href="http://www.beachmetro.com/category/columns/archived-columns/money-life-and-law/">Money, Life and Law</a></li>
		<li class="menu-school-views"><a href="http://www.beachmetro.com/category/columns/archived-columns/school-views/">School Views</a></li>
		<li class="menu-school-daze"><a href="http://www.beachmetro.com/category/columns/archived-columns/school-daze/">School Daze</a></li>
		<li class="menu-welcome-at-home"><a href="http://www.beachmetro.com/category/columns/archived-columns/welcome-at-home/">Welcome at Home</a></li>
		<li class="menu-where-are-they-now"><a href="http://www.beachmetro.com/category/columns/archived-columns/where-are-they-now/">Where Are They Now?</a></li>
		<li class="menu-write-on-health"><a href="http://www.beachmetro.com/category/columns/archived-columns/write-on-health/">Write on Health</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-letters"><a href="http://www.beachmetro.com/category/letters/">Letters</a></li>
<li class="menu-directory"><a href="http://www.beachmetro.com/top-menu-items/business-directory/">Directory</a></li>
<li class="menu-classifieds"><a href="http://www.beachmetro.com/top-menu-items/classifieds/">Classifieds</a></li>
</ul>						<div class="hidden-xs hidden-sm">		<ul class="nav navbar-nav navbar-right">
			<li class="facebook"><a href="http://www.facebook.com/BeachMetroNews" class="external" rel="nofollow" target="_blank"><i class="fa fa-facebook"></i></a></li><li class="twitter"><a href="http://twitter.com/beachmetronews" class="external" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i></a></li>			<li class="rss"><a href="http://www.beachmetro.com/feed/"><i class="fa fa-rss"></i></a></li>
		</ul>
	</div>
					</div>
				</nav>

								<div class="under-navigation hidden-xs hidden-sm">
					<div class="row">
						<div class="col-md-9 hidden-xs hidden-sm">		<aside id="news-ticker-3" class="widget dw_focus_widget_news_ticker">		<h2 class="widget-title">Trending Now</h2>		<div class="news-ticker-wrap headlines" data-interval="4000">
			<ul>
							<li>
					<a href="http://www.beachmetro.com/2017/04/24/city-seeks-input-prohibited-animals-list/">City seeks input on prohibited animals list</a>
									<span class="post-date">April 24, 2017</span>
								</li>
							<li>
					<a href="http://www.beachmetro.com/2017/04/24/street-fair-beer-garden-coming-queen-east-may/">Street fair and beer garden coming to Queen East this May</a>
									<span class="post-date">April 24, 2017</span>
								</li>
							<li>
					<a href="http://www.beachmetro.com/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/">Sweet citrus and decadent chocolate are sure to delight the senses</a>
									<span class="post-date">April 24, 2017</span>
								</li>
							<li>
					<a href="http://www.beachmetro.com/2017/04/23/beach-books-beach-poet-celebrates-second-collection/">Beach Books: Beach poet celebrates second collection</a>
									<span class="post-date">April 23, 2017</span>
								</li>
							<li>
					<a href="http://www.beachmetro.com/2017/04/22/courageous-voices-helps-students-find-voice/">&#8216;Courageous Voices&#8217; helps students find their voice</a>
									<span class="post-date">April 22, 2017</span>
								</li>
						</ul>
		</div>
		</aside>		</div>
						<div class="col-md-3"><form method="get" id="searchform" action="http://www.beachmetro.com/">
	<input type="text" name="s" id="s" class="form-control" value="" placeholder="Search">
	<input type="submit" class="search-submit">
</form>
</div>
					</div>
				</div>
							</div>
		</div>
	</header>

	<div id="content" class="site-content">
<div class="container">
	<div class="content-inner">
		<div class="row">
			<div class="col-lg-9">
				<div id="primary" class="content-area">
					<main id="main" class="site-main" role="main">
											
												
	<article id="post-23998" class="post-23998 post type-post status-publish format-standard has-post-thumbnail hentry category-the-main-menu tag-baked-goods tag-baking tag-hazelnut-mocha-torte tag-lemon-loaf">
		<header class="entry-header">
			<h1 class="entry-title">Sweet citrus and decadent chocolate are sure to delight the senses</h1>
			<div class="entry-meta">
				<span class="posted-on"><i class="fa fa-clock-o"></i> <a href="http://www.beachmetro.com/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/" rel="bookmark"><span class="entry-date published">April 24, 2017</span><span class="updated sr-only">April 18, 2017</span></a></span><span class="byline"> <i class="fa fa-user"></i> <span class="author vcard">Jan Main</span></span></span>
			</div>
		</header>

		

	<div class="row">
		<div class="entry-content col-md-9 col-md-push-3">
							<div class="entry-thumbnail"><img width="3364" height="2242" src="http://www.beachmetro.com/wp-content/uploads/2017/04/Lemons_5836497465.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://www.beachmetro.com/wp-content/uploads/2017/04/Lemons_5836497465.jpg 3364w, http://www.beachmetro.com/wp-content/uploads/2017/04/Lemons_5836497465-300x200.jpg 300w, http://www.beachmetro.com/wp-content/uploads/2017/04/Lemons_5836497465-768x512.jpg 768w, http://www.beachmetro.com/wp-content/uploads/2017/04/Lemons_5836497465-1024x682.jpg 1024w, http://www.beachmetro.com/wp-content/uploads/2017/04/Lemons_5836497465-230x153.jpg 230w" sizes="(max-width: 3364px) 100vw, 3364px" /><div class="ccfic"><span class="ccfic-text">Choose lemons that give to the touch, this means they have more lemon juice.</span></div></div>
						<a id="dd_start"></a><p>There’s no getting away from it – sweets are my downfall! But not just any sweet thing. Keep your nondescript candy, ice-cream and sugary fluffy desserts to yourself. But, a sensational sweet &#8212; that’s another matter. I like my sweets rich, bursting with intense flavour, preferably lemon, and if it should be chocolate – it must be quality dark chocolate, none of that milk chocolate nonsense. Treats have to be worth every calorie.</p>
<p>Sweetie Pie, here are two desserts, suitable for sampling by the most discerning sweet tooth!</p>
<hr />
<p><strong>Lily’s Simply Luscious Lemon Loaf</strong></p>
<p>Lemon is one of my all-time weaknesses. I have sampled many a lemon dessert, but when Lily Levitt sent this to me, one bite was enough to say, “More, please!” Lily kindly shared this recipe with me to give to you. Make and enjoy every last lemony crumb. Divine.</p>
<p><em>Tip: Choose lemons that give to the touch, this means they have more lemon juice. One juicy lemon produces 1/4 cup (50 mL) juice. It is easier to grate the lemon rind first then squeeze the juice. </em></p>
<p><strong>Cake:</strong></p>
<p>1 1/2 cups (375 mL) all-purpose flour</p>
<p>2 tsp (10 mL) baking powder</p>
<p>1/2 tsp (2 ml) salt</p>
<p>1 cup (250 mL) plain yogurt</p>
<p>1 cup (250 mL) granulated sugar</p>
<p>3 large or extra-large eggs</p>
<p>2 tsp (10 mL) grated lemon rind</p>
<p>1/2 tsp (2 mL) pure vanilla extract</p>
<p>1/2 cup (125 mL) vegetable oil</p>
<p><strong>Lemon Drizzle:</strong></p>
<p>1/2 cup (125 mL) granulated sugar</p>
<p>1/2 cup (125 mL) fresh lemon juice (2 lemons)</p>
<p><strong>Lemon Glaze:</strong></p>
<p>1 cup (250 mL) sifted icing sugar</p>
<p>2 tbsp (25 mL)  fresh lemon juice</p>
<p>Preheat oven to 350 F (180 C). Line an 8 1/2&#215;4 1/2 x 2 1/2 loaf pan with parchment paper. Set aside.</p>
<p>Sift together flour, baking powder and salt into one bowl.</p>
<p>In another mixing bowl, whisk together yogurt, sugar, eggs, lemon rind and vanilla.</p>
<p>Slowly whisk the dry ingredients into the wet ingredients.</p>
<p>Using a rubber spatula, fold the vegetable oil into the batter making sure it’s well combined. Pour the batter into the prepared loaf pan and bake in pre-heated oven for about 50 – 60 minutes or until cake tester inserted into center of loaf comes out clean. Cool on cooling rack.</p>
<p>Drizzle: Meanwhile in small stainless steel saucepan over medium-high heat, cook stirring the sugar and lemon juice until the sugar is dissolved and mixture is clear. Set aside.</p>
<p>Glaze: In small bowl, whisk together icing sugar and lemon juice until well blended. It will be thick.</p>
<p>While still warm, poke the lemon loaf with toothpick or piece of spaghetti all over surface of loaf at 1 inch (2.5 cm) intervals. Pour over the prepared drizzle and allow to sink in. Let loaf cool completely.</p>
<p>Once loaf has cooled, remove loaf from pan, spread glaze on top surface of loaf.</p>
<p>Wrap in plastic wrap and overwrap in foil and refrigerate for up to one week or freeze up to 2 months. Makes 12 delectable slices.</p>
<hr />
<p><strong>Daphne’s Decadent Delight (or Hazelnut Mocha Torte)</strong></p>
<p>Originally my Mother’s recipe, this is one of my husband’s favourites, so much so, that it became his birthday cake. Quite addictive and very rich, cut in small squares and hide! Although you can freeze this, it never seems to last long. Alas!</p>
<p>For special occasions, make in a 9 inch (23 cm ) round cake pan, cut into thin wedges and serve with a cup of hot, strong coffee.</p>
<p><strong>Base Layer:</strong></p>
<p>1/2 cup (125 ml) butter melted</p>
<p>21/2 cups (625 mL) graham wafer crumbs</p>
<p>1 cup (250 mL) toasted hazelnuts (filberts), chopped</p>
<p>1/4 cup (40 mL) sifted cocoa</p>
<p>1/4 cup (50 mL) granulated sugar</p>
<p>1 egg, beaten</p>
<p><strong>Coffee Filling:</strong></p>
<p>1/4 cup (50 mL) soft butter</p>
<p>2 – 2 1/2 cups (500 mL) sifted icing sugar</p>
<p>1 tbsp (15 mL)     hot strong coffee</p>
<p>1 tsp (5 mL) vanilla</p>
<p><strong>Chocolate Topping:</strong></p>
<p>1 cup (6 oz) quality semi or bittersweet chocolate, chopped, melted</p>
<p>Line a 9 inch (23 cm) square pan with parchment paper. Preheat oven to 350 F (180 C).</p>
<p>Toast hazelnuts on parchment lined baking sheet for 10 – 15 minutes or until golden and fragrant. Sprinkle hazelnuts on clean tea towel and rub to remove outer skin. Coarsely chop nuts and set aside. In mixing bowl, stir together butter, crumbs, chopped hazelnuts, cocoa, sugar and beaten egg until smooth. Press evenly into prepared baking pan. Bake 10 minutes. Cool on cooling rack. Meanwhile in mixing bowl, using electric mixer beat butter until fluffy and gradually beat in sifted icing sugar, coffee and vanilla. Beat until smooth and creamy. Once base layer is cool, spread coffee filling evenly on top. Refrigerate or freeze.</p>
<p>Melt chocolate in mixing bowl over saucepan of simmering water. Pour chocolate over cool coffee layer and spread evenly out to edges. Refrigerate until chocolate is firm.</p>
<p>To cut, use sharp knife dipped into hot water and cut into 30 pieces. May be wrapped and frozen.</p>
<p>My apologies to my readers, but the eggs were left out of the Make Ahead Brunch Casserole in my April 4 column. The recipe calls for 6 eggs.</p>
<a id="dd_end"></a><div class='dd_outer'><div class='dd_inner'><div id='dd_ajax_float'><div class='dd_button_v'><a href="http://twitter.com/share" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'http://twitter.com/share', '']);" class="twitter-share-button external" data-url="http://www.beachmetro.com/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/" data-count="vertical" data-text="Sweet citrus and decadent chocolate are sure to delight the senses" data-via="" rel="nofollow" target="_blank"></a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script></div><div style='clear:left'></div><div class='dd_button_v'><a href="http://www.facebook.com/sharer.php" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'http://www.facebook.com/sharer.php', '']);" name='fb_share' type='box_count' share_url='http://www.beachmetro.com/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/' class="external" rel="nofollow" target="_blank"></a><script src='http://static.ak.fbcdn.net/connect.php/js/FB.Share' type='text/javascript'></script></div><div style='clear:left'></div><div class='dd_button_v'><script type='text/javascript' src='https://apis.google.com/js/plusone.js'></script><g:plusone size='tall' href='http://www.beachmetro.com/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/'></g:plusone></div><div style='clear:left'></div><div class='dd_button_extra_v'><script type="text/javascript">jQuery(document).load(function(){ stLight.options({publisher:''}); });</script><div class="st_email_custom"><span id='dd_email_text'>email</span></div></div><div style='clear:left'></div><div class='dd_button_extra_v'><div id='dd_print_button'><span id='dd_print_text'><a href='javascript:window:print()'>print</a></span></div></div><div style='clear:left'></div></div></div></div><script type="text/javascript">var dd_offset_from_content = 40;var dd_top_offset_from_content = 0;var dd_override_start_anchor_id = "";var dd_override_top_offset = "";</script><script type="text/javascript" src="http://www.beachmetro.com/wp-content/plugins/digg-digg//js/diggdigg-floating-bar.js?ver=5.3.6"></script>						</div>
			<div class="entry-sidebar col-md-3 col-md-pull-9">
								
			</div>
		</div>


	</article>
												
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://www.beachmetro.com/2017/04/23/beach-books-beach-poet-celebrates-second-collection/" rel="prev">Beach Books: Beach poet celebrates second collection</a></div><div class="nav-next"><a href="http://www.beachmetro.com/2017/04/24/street-fair-beer-garden-coming-queen-east-may/" rel="next">Street fair and beer garden coming to Queen East this May</a></div></div>
	</nav>						
<section id="comments" class="comments">
	
	<a href="beach-metro-news-commenting-guidelines-policy" target="_new">Click here</a> for our commenting guidelines.
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/04/24/sweet-citrus-decadent-chocolate-sure-delight-senses/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.beachmetro.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form"><label for="comment">Comment</label><textarea id="comment" name="comment" class="form-control" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" class="form-control" aria-required=true /></p>
<p class="comment-form-email"><label for="email">Email</label> <span class="required">*</span><input id="email" name="email" type="text" value="" class="form-control" aria-required=true /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-default" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='23998' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f2a8efacad" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="210"/></p>			</form>
			</div><!-- #respond -->
	</section>										</main>
				</div>
			</div>
			<div class="col-lg-3">
				
<div id="secondary" class="widget-area" role="complementary">
	<aside id="recent-comments-5" class="widget widget_recent_comments"><h2 class="widget-title">WHAT PEOPLE ARE SAYING</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Jose</span> on <a href="http://www.beachmetro.com/2017/04/21/cherry-blossom-tree-tunnel-coming-beach/#comment-453519">Cherry blossom tree tunnel coming to the Beach</a></li><li class="recentcomments"><span class="comment-author-link">Bob</span> on <a href="http://www.beachmetro.com/2017/04/21/cherry-blossom-tree-tunnel-coming-beach/#comment-453516">Cherry blossom tree tunnel coming to the Beach</a></li><li class="recentcomments"><span class="comment-author-link">James Jewell</span> on <a href="http://www.beachmetro.com/2017/04/06/no-parking-hours-extended-east-end/#comment-453502">&#8216;No parking&#8217; hours extended in the East End</a></li><li class="recentcomments"><span class="comment-author-link">Rob Simpson</span> on <a href="http://www.beachmetro.com/2016/05/17/tour-former-town-east-toronto/#comment-453497">A tour through the former town of East Toronto</a></li><li class="recentcomments"><span class="comment-author-link">Kathryn Gardener</span> on <a href="http://www.beachmetro.com/2017/04/21/cherry-blossom-tree-tunnel-coming-beach/#comment-453485">Cherry blossom tree tunnel coming to the Beach</a></li></ul></aside><aside id="text-13" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive 1 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3515823420161132"
     data-ad-slot="4234949459"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside></div>
			</div>
		</div>
	</div>
</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="container">
			<div class="footer-navigation"></div>
<div id="footer-widgets" class="widget-area" role="complementary">
	<div class="row">
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-7" class="widget widget_nav_menu"><ul id="menu-bottom-left" class="menu"><li class="menu-become-a-volunteer"><a href="http://www.beachmetro.com/bottom-left-items/become-a-volunteer/">Become a Volunteer</a></li>
<li class="menu-frequently-asked-questions"><a href="http://www.beachmetro.com/bottom-left-items/faq/">Frequently Asked Questions</a></li>
<li class="menu-contact-us"><a href="http://www.beachmetro.com/bottom-left-items/contact-us/">Contact Us</a></li>
<li class="menu-about-us"><a href="http://www.beachmetro.com/bottom-left-items/about-us/">About Us</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-8" class="widget widget_nav_menu"><ul id="menu-bottom-middle" class="menu"><li class="menu-distribution-map"><a href="http://www.beachmetro.com/bottom-middle-items/distribution-map/">Distribution Map</a></li>
<li class="menu-2017-publication-schedule"><a href="http://www.beachmetro.com/bottom-middle-items/publication-schedule/">2017 Publication Schedule</a></li>
<li class="menu-advertising-rates"><a href="http://www.beachmetro.com/bottom-middle-items/advertising-rates/">Advertising Rates</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-sm-2"><aside id="nav_menu-9" class="widget widget_nav_menu"><ul id="menu-bottom-right" class="menu"><li class="menu-careers"><a href="http://www.beachmetro.com/careers/">Careers</a></li>
<li class="menu-suddicks-take"><a href="http://www.beachmetro.com/category/suddicks-take/">Suddick&#8217;s Take</a></li>
</ul></aside></div>
		<div class="col-lg-3 col-md-4 col-lg-offset-0 col-md-offset-2 col-sm-5 col-sm-offset-1"></div>
	</div>
</div>
			<div class="row">
				<div class="site-info col-md-6">
					Copyright &copy; 2017 by <br><a href="http://www.beachmetro.com" rel="designer">Beach Metro Community News</a>.					<br>
				</div>

			</div>
		</div>
	</footer>
</div>

<!-- Start Of Script Generated By Greg's Comment Length Limiter Plugin 1.6.5 -->
<script type="text/javascript">
<!--
function gcllCounter(textarea) {
if (textarea.value.length > 1500)
textarea.value = textarea.value.substring(0, 1500);
else
document.getElementById('commentlen').value = 1500 - textarea.value.length;
}
//-->
</script>
<!-- End of Script Generated By Greg's Comment Length Limiter Plugin 1.6.5 --><style type="text/css">a { color: #487db6}
a:hover, a:active { color: #ba534a}
body { background: url() #474747 repeat top center scroll}
.site-header { background: url()  repeat top center scroll}
.site-footer { color: #555555}
.site-footer a { color: #777777}
.site-footer a:hover, .site-footer a:active { color: #ffffff}
.site-footer #footer-widgets .widget-title { color: #ffffff}
.site-footer .footer-navigation, #footer-widgets { border-color: #a8a8a8}
#footer-widgets .widget_nav_menu:after { background-color: #a8a8a8}
 .site-footer { background: url() #01202b repeat top center scroll}
body { color:#333333; font-family:Roboto Slab, serif; font-size:14px; }
h1 { color:#333333; font-family:Oswald, sans-serif; font-size:36px; }
h2 { color:#333333; font-family:Oswald, sans-serif; font-size:30px; }
h3 { color:#333333; font-family:Oswald, sans-serif; font-size:30px; }
h4 { color:#333333; font-family:Oswald, sans-serif; font-size:18px; }
h5 { color:#333333; font-family:Oswald, sans-serif; font-size:14px; }
h6 { color:#333333; font-family:PT Sans, sans-serif; font-size:12px; }
</style><script type='text/javascript' src='http://www.beachmetro.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='http://w.sharethis.com/button/buttons.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-includes/js/comment-reply.min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"http:\/\/www.beachmetro.com\/wp-admin\/admin-ajax.php"};
var sharrre = {"sharrre_url":"http:\/\/www.beachmetro.com\/wp-content\/themes\/dw-focus\/inc\/sharrre.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-content/themes/dw-focus/assets/js/dw-focus.min.js?ver=1.2.6'></script>
<script type='text/javascript' src='http://www.beachmetro.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>

</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

 Served from: beachmetro.com @ 2017-04-25 00:00:14 by W3 Total Cache -->